Bug-Tracker

Le carré VIP, incontournable pour les connaisseurs

Bug-Tracker

Messagepar ZDS » 11 Mar 2013, 03:00

Dans ce topic, l'équipe nAiO listera les différents bugs rencontrés et l'état d'avancement de la correction.
Ci-joint le modèle BBCode pour les messages de bug :
Code: Tout sélectionner
[b]Type[/b] : Téléchargement/Installation/Utilisation/Autre (information)
[b]Elément[/b] : nAiO/NomDuModule/Autre
[b]Lien[/b] : [url]http://www.naio.fr/xxxxxxxxxxxxxx[/url]
[b]Résumé[/b] : Phrase simple pour décrire le bug
[b]Avancement[/b] : [list][*]Date1 - Status, info[*]Date2 - Status, info[*]...[/list]
[spoiler=Description]Description du problème, et possibilités de corrections.[/spoiler]
Status possibles:
  • En analyse : Bug présent chez certaines personnes mais non reproduit, complément souhaitable.
  • En diagnostic : Bug présent et reproduit, cause encore inconnue.
  • En correction : Correction du bug et développement du code correspondant en cours.
  • En validation : Bug corrigé, en cours de validation pour éviter les régressions.
  • Résolu : Bug corrigé et présenté dans une nouvelle version, attente de confirmation des utilisateurs.
  • Corrigé : Bug corrigé et confirmé par les utilisateurs.
  • Réouvert : Correction insuffisante de la part des utilisateurs.
Une fois le bug en situation "Résolu" ou plus avancé, indiquez une autre balise BBCode dans le message :
Code: Tout sélectionner
[b]Correction[/b] : Marche à suivre pour corriger le problème
Avatar de l’utilisateur
ZDS
Fondateur [Equipe nAiO]
 
Messages: 508

Bug #001 - En analyse

Messagepar ZDS » 30 Mar 2013, 02:19

Type : Utilisation (raccourcis)
Elément : Mininit
Lien : http://www.naio.fr/viewtopic.php?f=14&t=47
Résumé : Les touches Fx ne sont pas utilisables
Avancement :
  • 30/03/2013 - En analyse
Description :
Il se peut que cela vienne de l'encapsulation des raccourcis par des { } dans le code, ou alors les touches Fx ne sont pas correctement utilisables par l'OS (conflit comme annoncé pour la touche F12 réservée à Windows). A vérifier et à corriger
Avatar de l’utilisateur
ZDS
Fondateur [Equipe nAiO]
 
Messages: 508

Bug #002 - Résolu

Messagepar ZDS » 03 Avr 2013, 14:44

Type : Utilisation (calibrage)
Elément : Connexion
Lien : http://www.naio.fr/viewtopic.php?f=14&t=41
Résumé : Problème de calibrage pour les multis
Avancement :
  • 19/03/2013 - En analyse
  • 02/04/2013 - En correction, nom de compte impacté mais pas le pass, information non négligeable
  • 03/04/2013 - En validation, pas d'impact de régression possible
  • 03/04/2013 - Résolu, lien du correctif : Connexion 1.4a (source)
Description :
Le bug se reproduit uniquement sur les fenêtres dont l'activation n'est pas encore faite, car le positionnement par défaut du cliqueur se fait en fonction de la fenêtre ayant le focus (le nAiO dans le cas des autres fenêtres que la première). Il suffit donc de redonner le focus avant de chercher à cliquer dans les champs vides (par sécurité, avant même de détecter les champs vides).

Correction rapide dans le code source :
Remplacer vers la ligne 437 :
Code: Tout sélectionner
      ; Activation de la fenêtre pour le compte n°$i
      WinSetState($fenetre,"",@SW_SHOW)
par le bloc suivant :
Code: Tout sélectionner
      ; Activation de la fenêtre pour le compte n°$i
      WinSetState($fenetre,"",@SW_SHOW)
      WinActivate($fenetre)
Correction : Remplacer le fichier Connexion.exe du répertoire "Modules" par celui du correctif
Avatar de l’utilisateur
ZDS
Fondateur [Equipe nAiO]
 
Messages: 508

Bug #003 - Résolu

Messagepar ZDS » 04 Avr 2013, 19:17

Type : Utilisation (calibrage)
Elément : Connexion
Lien : http://www.naio.fr/viewtopic.php?f=14&t=395
Résumé : Problème de sélection de fenêtres pour les multis, à cause du Reg Audio Subsystem
Avancement :
  • 04/04/2013 - En analyse
  • 04/04/2013 - En correction, détection du titre exact lors des prochaines sélections de fenêtres
  • 06/04/2013 - Résolu, faux-bug dû à une mise à jour incorrecte
Description :
Le bug se reproduit seulement sur certaines configurations, son origine n'est pas déterminée. Mais il suffit de restreindre les critères de sélection des fenêtres candidates : "REGEXPTITLE:Dofus" prend en compte toutes les fenêtres dont le titre contient "Dofus", ce qui est aussi le cas du RAS; en remplaçant par "REGEXPTITLE:^Dofus$" les seuls titres candidats seront ceux qui commencent "^" et qui finissent "$" par "Dofus".
Palliatif : Editez le fichier "Connexion.ini" dans le répertoire "Modules/Connexion" puis remplacez la ligne :
Code: Tout sélectionner
DofusMod_WinMatch=[REGEXPTITLE:Dofus; CLASS:ApolloRuntimeContentWindow]
par la suivante :
Code: Tout sélectionner
DofusMod_WinMatch=[REGEXPTITLE:^Dofus$; CLASS:ApolloRuntimeContentWindow]
Attention : faire un calibrage après la modification écrasera la modification en question
Avatar de l’utilisateur
ZDS
Fondateur [Equipe nAiO]
 
Messages: 508

Bug #004 - Résolu

Messagepar ZDS » 12 Avr 2013, 19:45

Type : Utilisation (connexion automatisée)
Elément : Connexion
Lien : http://www.naio.fr/viewtopic.php?f=14&t=409
Résumé : Désactivation des infobulles lors de la connexion
Avancement :
  • 12/04/2013 - En analyse
  • 12/04/2013 - En correction, ajout d'un bouton de désactivation dans l'interface de config du module
  • 12/04/2013 - En validation, pas d'impact de régression possible, et fusion avec les corrections en cours
  • 12/04/2013 - Résolu, lien du correctif : Connexion 1.4b (source)
Description :
La demande d'évolution faite par Quiorell venait du fait que, les infobulles devenant omniprésentes lors de la connexion, on pouvait penser qu'il y avait un souci. La demande visait donc un aspect cosmétique et ergonomique du connecteur.
Mais ce genre d'infobulles pouvaient aussi entraver le fonctionnement, ce qui en faisait un bug à proprement parler (sur un écran trop petit comme un netbook en 1024x600, les bulles et les fenetres peuvent se chevaucher, et les clics pouvaient se faire sur la bulle au lieu de la fenêtre de jeu, faisant ainsi planter la suite de la procédure).
Correction : Remplacer le fichier Connexion.exe du répertoire "Modules" par celui du correctif
Avatar de l’utilisateur
ZDS
Fondateur [Equipe nAiO]
 
Messages: 508

Bug #005 - Résolu

Messagepar ZDS » 28 Avr 2013, 13:40

Type : Utilisation (calibrage)
Elément : Connexion
Lien : http://www.naio.fr/viewtopic.php?f=14&t=433
Résumé : Calibrage et gestion du son
Avancement :
  • 27/04/2013 - En analyse
  • 28/04/2013 - En correction, utilisation du ShellExecute à la place du Run dans le code
  • 28/04/2013 - En correction, autorisation d'utiliser les fichier .lnk à la place des .exe
  • 28/04/2013 - Résolu, lien du correctif : Connexion 1.4c (source)
Description :
Suite aux descriptifs et à la constatation du problème via Skype, le problème de Cozzah vient du RegAudioSystem qui n'est pas lié au client de jeu lorsque celui-ci est lancé par le nAiO (le répertoire de travail du raccourci, aka le champ "Démarrer dans", correspond pas toujours au répertoire de base de l'UpLauncher); la version 1.4b du connecteur est incapable de faire la résolution.
Le paliatif [Run => ShellExecute] permet de choisir des raccourcis (lnk) et de forcer ainsi le connecteur à utiliser le bon répertoire de travail. Le choix des LNK (raccourcis Windows) à la place des EXE permet de d'effectuer des choix précis de répertoire de travail.
Correction : Remplacer le fichier Connexion.exe du répertoire "Modules" par celui du correctif
Avatar de l’utilisateur
ZDS
Fondateur [Equipe nAiO]
 
Messages: 508

Bug #006 - En correction

Messagepar Famille Za » 16 Sep 2013, 02:55

Type : Utilisation
Elément : Mininit
Lien : http://naio.fr/viewtopic.php?f=14&t=38
Résumé : Le dernier compte de la liste n'est pas reconnu
Avancement :
  • 10/09/2013 - Vérification de la correction
Description :
Problème remonté assez rapidement sur les forums, le dernier compte affiché dans le Mininit n'est pas utilisable par Suivante/Précédente, voire n'est pas du tout présent dans la liste.
Contournement : Ouvrir un fichier bloc-notes portant un nom placé après dans l'alphabet ("zzzz" par exemple)
Correction : Remplacer le fichier Mininit.exe du répertoire "Modules" par celui du correctif
Famille Za
Fondateur [Equipe nAiO]
 
Messages: 26

Bug #007 - En correction

Messagepar Famille Za » 16 Sep 2013, 03:03

Type : Utilisation
Elément : Mininit
Résumé : La touche Échap ne répond plus
Avancement :
  • 10/09/2013 - Vérification de la correction
Description :
La touche Échap ne répond parfois plus lors de l'utilisation du Mininit.
Cette touche servait à mettre en pause le module, notamment utile lors des sessions de tests de développement. Il n'y a pas de fonction active dans le module, qui n'a donc pas besoin d'être mis en pause par l'utilisateur.
Correction : Remplacer le fichier Mininit.exe du répertoire "Modules" par celui du correctif
Famille Za
Fondateur [Equipe nAiO]
 
Messages: 26

Bug #008 - Résolu

Messagepar ZDS » 21 Fév 2014, 10:49

Type : Utilisation (connexion automatisée)
Elément : Connexion
Lien : http://www.naio.fr/viewtopic.php?f=25&t=917
Résumé : Incompatibilité avec le nouvel UpLauncher de Dofus
Avancement :
  • 20/12/2013 - En analyse, préparation de corrections envisageables
  • 20/02/2014 - En correction, modification importante du système de détection des éléments utilisables
  • 20/02/2014 - En validation, régression possible, passage à une version majeure supérieure 2.X
  • 20/02/2014 - Résolu, lien du correctif : Connexion 2.0 (source)
  • 21/02/2014 - Résolu, lien du correctif : Connexion 2.0a (source)
Description :
Ankama ayant mis à disposition un nouveau gestionnaire de lancement du jeu (et de mise à jour), le fonctionnement du connecteur Connexion n'était plus du tout compatible. Une refonte totale de la détection des éléments sur cet uplauncher est à implémenter.
Correction : Remplacer le fichier Connexion.exe du répertoire "Modules" par celui du correctif
Avatar de l’utilisateur
ZDS
Fondateur [Equipe nAiO]
 
Messages: 508


Retourner vers Coin des développeurs

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité